WhatsApp support ending for older Android devices starting today

Fragmentation may be the bane of Android but it doesn’t mean that, as the platform advances, many more are being left behind.

While the data may be scarce since Google has since stopped publishing its monthly platform distribution figures, we have a rough idea how things look: more and more people are upgrading to newer versions, even if that takes a long time.

As if that is not enough, the last time that Google updated its publicly available platform distribution page, devices powered by versions of Android released before 5.0 Lollipop’s arrival 5 years ago accounted for only a little over 10% of all Android devices with regular access to the Play Store.

Even then, only a negligible 0.3% of all Android devices still ran on the dated Android 2.x platform.

As such, it comes as no surprise that starting today, WhatsApp is continuing its push to drop devices on that Android 2.x platform.

Because we no longer actively develop for these operating systems, some features might stop functioning at any time.

In an update provided late last year, WhatsApp noted that effective today, users of devices running on Android 2.3.7 (Gingerbread) and below would be unable to create new accounts or reverify existing accounts.

That is to mean that for those who are still hanging on to their Jurassic-era devices, they can continue using WhatsApp on those devices if the app is already installed and signed on to but they won’t be able to onboard new mobile numbers to the service from such devices or, when prompted to, confirm their existing accounts.

READ:  WhatsApp testing Disappearing Messages feature

Going forward, WhatsApp will only support devices running on Android 4.0.3 (Ice Cream Sandwich) and up.

Have something that you believe I need to have a look at? Hit me up: echenze [at] androidkenya.com